aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorfiaxh <git@lightrise.org>2019-11-17 17:30:40 +0100
committerfiaxh <git@lightrise.org>2019-11-17 17:31:40 +0100
commit2811eaf7c506f0147ac41bd12500502d733cba93 (patch)
tree3a036f93ce3595b5581e55a99a584d9928bd75b0 /CMakeLists.txt
parent65feaece8712e62cbc63da18fdd83fd7d0324179 (diff)
downloaddino-2811eaf7c506f0147ac41bd12500502d733cba93.tar.gz
dino-2811eaf7c506f0147ac41bd12500502d733cba93.zip
Disable fast vapi generation for vala 0.44.10, 0.46.4 and 0.47.1
fixes #646
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ba9d93dd..9e007ad3 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -124,8 +124,8 @@ if(NOT VALA_EXECUTABLE)
endif()
find_package(Vala 0.34 REQUIRED)
-if(VALA_VERSION VERSION_GREATER "0.34.90" AND VALA_VERSION VERSION_LESS "0.36.1")
- # Due to a bug on 0.36.0 (and pre-releases), we need to disable FAST_VAPI
+if(VALA_VERSION VERSION_GREATER "0.34.90" AND VALA_VERSION VERSION_LESS "0.36.1" OR # Due to a bug on 0.36.0 (and pre-releases), we need to disable FAST_VAPI
+ VALA_VERSION VERSION_EQUAL "0.44.10" OR VALA_VERSION VERSION_EQUAL "0.46.4" OR VALA_VERSION VERSION_EQUAL "0.47.1") # See Dino issue #646
set(DISABLE_FAST_VAPI yes)
endif()