aboutsummaryrefslogtreecommitdiff
path: root/crypto-vala/meson.build
diff options
context:
space:
mode:
authorMiquel Lionel <lionel@les-miquelots.net>2023-10-30 21:48:08 +0100
committerMiquel Lionel <lionel@les-miquelots.net>2023-10-30 21:48:08 +0100
commitd761e8ccd5293d2f30a889b0cbe302c985aee68c (patch)
tree922bb248a7fee4cdff3da114abc7d77200f3d0da /crypto-vala/meson.build
parent302e954c99c71d670201828c6746dfaa40276d6d (diff)
parent3de716446819550514d50a8112f5b6dd0c662702 (diff)
downloaddino-d761e8ccd5293d2f30a889b0cbe302c985aee68c.tar.gz
dino-d761e8ccd5293d2f30a889b0cbe302c985aee68c.zip
Show which account is currently used in conversation details in the about sectionadd_conversation_account_indicator
Diffstat (limited to 'crypto-vala/meson.build')
-rw-r--r--crypto-vala/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/crypto-vala/meson.build b/crypto-vala/meson.build
new file mode 100644
index 00000000..c3feb4d1
--- /dev/null
+++ b/crypto-vala/meson.build
@@ -0,0 +1,23 @@
+dependencies = [
+ dep_gio,
+ dep_glib,
+ dep_libgcrypt,
+ dep_libsrtp2,
+]
+sources = files(
+ 'src/cipher.vala',
+ 'src/cipher_converter.vala',
+ 'src/error.vala',
+ 'src/random.vala',
+ 'src/srtp.vala',
+)
+c_args = [
+ '-DG_LOG_DOMAIN="crypto-vala"',
+]
+vala_args = [
+ '--vapidir', meson.current_source_dir() / 'vapi',
+]
+lib_crypto_vala = library('crypto-vala', sources, c_args: c_args, vala_args: vala_args, dependencies: dependencies, version: '0.0', install: true, install_dir: [true, true, true])
+dep_crypto_vala = declare_dependency(link_with: lib_crypto_vala, include_directories: include_directories('.'))
+
+install_data('crypto-vala.deps', install_dir: get_option('datadir') / 'vala/vapi') # TODO: workaround for https://github.com/mesonbuild/meson/issues/9756