aboutsummaryrefslogtreecommitdiff
path: root/libdino/meson.build
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2024-08-01 15:33:56 +0200
committerMarvin W <git@larma.de>2025-01-12 20:00:51 +0100
commit613cb5e2d7c3f1469f4f91b86fa982eda472465b (patch)
treeea1315a2c1d48bcc91589aa3cee130eb1d96d533 /libdino/meson.build
parenta63b5ccb9a791d78ad7f5811f414ae8dab0c4f15 (diff)
downloaddino-613cb5e2d7c3f1469f4f91b86fa982eda472465b.tar.gz
dino-613cb5e2d7c3f1469f4f91b86fa982eda472465b.zip
Meson: Adjust version generation to match CMake
and be compatible with vala-language-server
Diffstat (limited to 'libdino/meson.build')
-rw-r--r--libdino/meson.build11
1 files changed, 2 insertions, 9 deletions
diff --git a/libdino/meson.build b/libdino/meson.build
index 85487d48..f88cbb06 100644
--- a/libdino/meson.build
+++ b/libdino/meson.build
@@ -1,18 +1,11 @@
# version_vala
dot_git = meson.current_source_dir() / '../.git'
version_file = meson.current_source_dir() / '../VERSION'
-command = [prog_python, files('version.py'), version_file, '@OUTPUT@', '--git-repo', meson.current_source_dir()]
+command = [prog_python, files('version.py'), version_file, '--git-repo', meson.current_source_dir()]
if prog_git.found()
command += ['--git', prog_git]
endif
-depend_files = []
-if fs.exists(dot_git)
- depend_files += [dot_git]
-endif
-if fs.exists(version_file)
- depend_files += [version_file]
-endif
-version_vala = custom_target('libdino_version_vala', command: command, output: 'version.vala', depend_files: depend_files)
+version_vala = vcs_tag(command: command, input: 'src/version.vala.in', output: 'version.vala', replace_string: '%VERSION%')
# libdino
dependencies = [