aboutsummaryrefslogtreecommitdiff
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorfiaxh <git@lightrise.org>2023-01-06 17:24:52 +0100
committerMarvin W <git@larma.de>2023-01-24 19:21:25 +0100
commit6a182ba313026b93d54a9d2246a0ab68894c6833 (patch)
treeedc6068c19363db1af725033521555c91bbfb0a9 /main/CMakeLists.txt
parentef98adb18a016dba65162602eb336fb82c64805e (diff)
downloaddino-6a182ba313026b93d54a9d2246a0ab68894c6833.tar.gz
dino-6a182ba313026b93d54a9d2246a0ab68894c6833.zip
Only use Adw.AboutWindow for Adwaita >= 1.2
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index c133a399..de5f2667 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -111,6 +111,9 @@ set(MAIN_DEFINITIONS)
if(GTK4_VERSION VERSION_GREATER_EQUAL "4.6")
set(MAIN_DEFINITIONS ${MAIN_DEFINITIONS} GTK_4_6)
endif()
+if(Adwaita_VERSION VERSION_GREATER_EQUAL "1.2")
+ set(MAIN_DEFINITIONS ${MAIN_DEFINITIONS} Adw_1_2)
+endif()
vala_precompile(MAIN_VALA_C
SOURCES