aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorhrxi <hrrrxi@gmail.com>2023-03-20 02:01:22 +0100
committerfiaxh <fiaxh@users.noreply.github.com>2023-03-24 19:32:50 +0100
commit5a90e793ddec723677f2b715b967f29f046e16d2 (patch)
tree6a96f142526990010635607cb547b79b9c3f060e /meson.build
parentb617bf7cc4ac2aa083bcf889816d0479fa353e10 (diff)
downloaddino-5a90e793ddec723677f2b715b967f29f046e16d2.tar.gz
dino-5a90e793ddec723677f2b715b967f29f046e16d2.zip
First steps of meson support
Basic configuration of qlite, xmpp-vala, the Dino library and the Dino application are supported. There's no support for the plugins. This e.g. enables using the Vala language server.
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 00000000..aea22d57
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,23 @@
+project('xmpp-vala', 'vala')
+
+fs = import('fs')
+python = import('python')
+
+dep_gdk_pixbuf = dependency('gdk-pixbuf-2.0')
+dep_gee = dependency('gee-0.8')
+dep_gio = dependency('gio-2.0')
+dep_glib = dependency('glib-2.0')
+dep_gmodule = dependency('gmodule-2.0')
+dep_gtk4 = dependency('gtk4')
+dep_icu_uc = dependency('icu-uc')
+dep_libadwaita = dependency('libadwaita-1')
+dep_m = meson.get_compiler('c').find_library('m', required: false)
+dep_sqlite3 = dependency('sqlite3', version: '>=3.24')
+
+prog_git = find_program('git', required: false)
+prog_python = python.find_installation()
+
+subdir('qlite')
+subdir('xmpp-vala')
+subdir('libdino')
+subdir('main')