aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2021-04-11 12:31:03 +0200
committerMarvin W <git@larma.de>2021-04-11 12:31:03 +0200
commit6ebdec1d78a7ad1b8668a2ba6eceb34515c75384 (patch)
tree1bbbe53125181e374506ee8bf5a14116c9c19b72 /plugins/rtp/CMakeLists.txt
parent5e11986838057a5cdbdf9d271316513da1bd4764 (diff)
downloaddino-6ebdec1d78a7ad1b8668a2ba6eceb34515c75384.tar.gz
dino-6ebdec1d78a7ad1b8668a2ba6eceb34515c75384.zip
GStreamer compat
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
index c6888459..0925ff0c 100644
--- a/plugins/rtp/CMakeLists.txt
+++ b/plugins/rtp/CMakeLists.txt
@@ -9,6 +9,10 @@ find_packages(RTP_PACKAGES REQUIRED
GstApp
)
+if(Gst_VERSION VERSION_GREATER "1.16")
+ set(RTP_DEFINITIONS GST_1_16)
+endif()
+
vala_precompile(RTP_VALA_C
SOURCES
src/codec_util.vala
@@ -25,6 +29,8 @@ CUSTOM_VAPIS
${CMAKE_BINARY_DIR}/exports/qlite.vapi
PACKAGES
${RTP_PACKAGES}
+DEFINITIONS
+ ${RTP_DEFINITIONS}
OPTIONS
--vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi
)