aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
authorSamuel Hand <sdhand@users.noreply.github.com>2018-05-28 15:19:51 +0100
committerfiaxh <fiaxh@users.noreply.github.com>2018-05-28 16:19:51 +0200
commit62e5e6485e75df355226e3d48ee23ea11aff223f (patch)
tree0dd41573e658aa1d377bfa4b257ad3f857bc5a3f /xmpp-vala/CMakeLists.txt
parent5425243203cbf5f86b33c4014c5aa787c6aae856 (diff)
downloaddino-62e5e6485e75df355226e3d48ee23ea11aff223f.tar.gz
dino-62e5e6485e75df355226e3d48ee23ea11aff223f.zip
Implement XEP-0380 for the OMEMO and OpenPGP plugins (#359)
* Implement XEP-0380 in a naive fashion for both the OMEMO and OpenPGP plugins * Move the XEP-0380 namespace to a constant * Move the implementation for xep-0380 to its own module * Remove un-needed lines from plugins/openpgp/src/stream_module.vala
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index 3190fad0..6734f0ee 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -68,6 +68,7 @@ SOURCES
"src/module/xep/0313_message_archive_management.vala"
"src/module/xep/0333_chat_markers.vala"
"src/module/xep/0368_srv_records_tls.vala"
+ "src/module/xep/0380_explicit_encryption.vala"
"src/module/xep/pixbuf_storage.vala"
PACKAGES
${ENGINE_PACKAGES}