aboutsummaryrefslogtreecommitdiff
path: root/crypto-vala/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'crypto-vala/meson.build')
-rw-r--r--crypto-vala/meson.build23
1 files changed, 23 insertions, 0 deletions
diff --git a/crypto-vala/meson.build b/crypto-vala/meson.build
new file mode 100644
index 00000000..c3feb4d1
--- /dev/null
+++ b/crypto-vala/meson.build
@@ -0,0 +1,23 @@
+dependencies = [
+ dep_gio,
+ dep_glib,
+ dep_libgcrypt,
+ dep_libsrtp2,
+]
+sources = files(
+ 'src/cipher.vala',
+ 'src/cipher_converter.vala',
+ 'src/error.vala',
+ 'src/random.vala',
+ 'src/srtp.vala',
+)
+c_args = [
+ '-DG_LOG_DOMAIN="crypto-vala"',
+]
+vala_args = [
+ '--vapidir', meson.current_source_dir() / 'vapi',
+]
+lib_crypto_vala = library('crypto-vala', sources, c_args: c_args, vala_args: vala_args, dependencies: dependencies, version: '0.0', install: true, install_dir: [true, true, true])
+dep_crypto_vala = declare_dependency(link_with: lib_crypto_vala, include_directories: include_directories('.'))
+
+install_data('crypto-vala.deps', install_dir: get_option('datadir') / 'vala/vapi') # TODO: workaround for https://github.com/mesonbuild/meson/issues/9756