aboutsummaryrefslogtreecommitdiff
path: root/plugins/signal-protocol/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/signal-protocol/CMakeLists.txt')
-rw-r--r--plugins/signal-protocol/CMakeLists.txt52
1 files changed, 4 insertions, 48 deletions
diff --git a/plugins/signal-protocol/CMakeLists.txt b/plugins/signal-protocol/CMakeLists.txt
index ea7dc9bb..b3cfae9d 100644
--- a/plugins/signal-protocol/CMakeLists.txt
+++ b/plugins/signal-protocol/CMakeLists.txt
@@ -28,54 +28,10 @@ GENERATE_HEADER
set(C_HEADERS_SRC "")
set(C_HEADERS_TARGET "")
-if(NOT BUILD_LIBSIGNAL_IN_TREE)
- # libsignal-protocol-c has a history of breaking compatibility on the patch level
- # we'll have to check compatibility for every new release
- # distro maintainers may update this dependency after compatibility tests
- find_package(SignalProtocol 2.3.2 REQUIRED)
-else()
- add_subdirectory(libsignal-protocol-c EXCLUDE_FROM_ALL)
- set_property(TARGET curve25519 PROPERTY POSITION_INDEPENDENT_CODE ON)
- set_property(TARGET protobuf-c PROPERTY POSITION_INDEPENDENT_CODE ON)
- set_property(TARGET signal-protocol-c PROPERTY POSITION_INDEPENDENT_CODE ON)
-
- set(SIGNAL_PROTOCOL_C_HEADERS
- signal_protocol.h
- signal_protocol_types.h
- curve.h
- hkdf.h
- ratchet.h
- protocol.h
- session_state.h
- session_record.h
- session_pre_key.h
- session_builder.h
- session_cipher.h
- key_helper.h
- sender_key.h
- sender_key_state.h
- sender_key_record.h
- group_session_builder.h
- group_cipher.h
- fingerprint.h
- device_consistency.h
- )
-
- file(MAKE_DIRECTORY "${CMAKE_BINARY_DIR}/exports/signal")
-
- foreach(f ${SIGNAL_PROTOCOL_C_HEADERS})
- list(APPEND C_HEADERS_SRC "${CMAKE_CURRENT_SOURCE_DIR}/libsignal-protocol-c/src/${f}")
- list(APPEND C_HEADERS_TARGET "${CMAKE_BINARY_DIR}/exports/signal/${f}")
- add_custom_command(OUTPUT "${CMAKE_BINARY_DIR}/exports/signal/${f}"
- COMMAND
- cp "${CMAKE_CURRENT_SOURCE_DIR}/libsignal-protocol-c/src/${f}" "${CMAKE_BINARY_DIR}/exports/signal/${f}"
- DEPENDS
- "${CMAKE_CURRENT_SOURCE_DIR}/libsignal-protocol-c/src/${f}"
- COMMENT
- Copy header file signal/${f}
- )
- endforeach(f)
-endif()
+# libsignal-protocol-c has a history of breaking compatibility on the patch level
+# we'll have to check compatibility for every new release
+# distro maintainers may update this dependency after compatibility tests
+find_package(SignalProtocol 2.3.2 REQUIRED)
list(APPEND C_HEADERS_SRC "${CMAKE_CURRENT_SOURCE_DIR}/src/signal_helper.h")
list(APPEND C_HEADERS_TARGET "${CMAKE_BINARY_DIR}/exports/signal_helper.h")