aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiquel Lionel <lionel@les-miquelots.net>2021-12-29 02:32:40 +0100
committerMiquel Lionel <lionel@les-miquelots.net>2021-12-29 12:28:27 +0100
commita01f8091c01889d7ca90938f56ae176a74da5590 (patch)
treeac9cccff3100f5754e9f09afbef02103f978e790 /CMakeLists.txt
parent96555dfc65034c46578309f39ae0f754e1acb0f8 (diff)
downloadkdeltachat-a01f8091c01889d7ca90938f56ae176a74da5590.tar.gz
kdeltachat-a01f8091c01889d7ca90938f56ae176a74da5590.zip
Implement notifications + "mute/unmute chat" menu
- Added icons: Pinned and muted chats have icons. It's from Twemoji font, I've added credits in the README.md and source code of ChatlistItem.qml. I prefer to rely on .PNG for this one because icon might not be installed or exist on the system, and we avoid the black box problem. - Modified CMakeLists: added KNotifications as a required library - Modified build.sh: I cannot comprehend how the install(FILES) function from cmake works, so I used good old install from GNU coreutils. It copies usr/ structure and needed files (.desktop and .notifyrc) for KNotifications to work. - Aesthetic changes: context menu is shorter now due to the text being state-aware. You can now also mute a chat so you won't be notified on incoming messages.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6584945..f10a4f8 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -55,6 +55,7 @@ add_executable(
find_package(Threads REQUIRED)
find_package(KF5Kirigami2 REQUIRED)
+find_package(KF5Notifications REQUIRED)
pkg_check_modules(DeltaChat IMPORTED_TARGET deltachat)
target_compile_definitions(
@@ -66,8 +67,7 @@ target_link_libraries(
Qt${QT_VERSION_MAJOR}::Widgets Qt${QT_VERSION_MAJOR}::WebEngine
PRIVATE Threads::Threads
PRIVATE KF5::Kirigami2
+ PRIVATE KF5::Notifications
PRIVATE PkgConfig::DeltaChat m dl)
install(TARGETS kdeltachat ${KDE_INSTALL_TARGETS_DEFAULT_ARGS})
-
-add_subdirectory(res)