aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiquel Lionel <lionel@les-miquelots.net>2022-02-06 20:42:01 +0100
committerMiquel Lionel <lionel@les-miquelots.net>2022-02-06 20:57:27 +0100
commitd5ad7202ea77e8a512073f9ce09b6c07e37d6305 (patch)
tree167141728086401a50a125a20997b61df41a2d2e /CMakeLists.txt
parenta01f8091c01889d7ca90938f56ae176a74da5590 (diff)
downloadkdeltachat-d5ad7202ea77e8a512073f9ce09b6c07e37d6305.tar.gz
kdeltachat-d5ad7202ea77e8a512073f9ce09b6c07e37d6305.zip
Move notifications to own header file
- also make a skel for files in /usr/, useful for sounds and notifyrc - build.sh use plain simple cp -r to copy the skel. also copies the knotifications5 in the current directory for qml.qrc embedding in case the app is used on android.
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f10a4f8..4817196 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -37,6 +37,7 @@ ecm_find_qmlmodule(org.kde.kirigami 2.12)
#
# See https://doc.qt.io/qt-5/qtquick-deployment.html#ahead-of-time-compilation
find_package(Qt5QuickCompiler REQUIRED)
+find_package(KF5Notifications REQUIRED)
qtquick_compiler_add_resources(KDELTACHAT_QML_QRC qml.qrc)
add_executable(
@@ -48,6 +49,7 @@ add_executable(
chatlist.cpp
contact.cpp
chat.cpp
+ notifications.cpp
eventemitter.cpp
lot.cpp
dcevent.cpp
@@ -55,7 +57,6 @@ add_executable(
find_package(Threads REQUIRED)
find_package(KF5Kirigami2 REQUIRED)
-find_package(KF5Notifications REQUIRED)
pkg_check_modules(DeltaChat IMPORTED_TARGET deltachat)
target_compile_definitions(