aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorhrxi <hrrrxi@gmail.com>2019-12-28 03:11:51 +0100
committerfiaxh <git@lightrise.org>2021-03-19 22:06:02 +0100
commit148cf48d2b68354881066e2587e2673c91d2619a (patch)
tree623c2eda8dda8d327084b36bc74120933be061bf /CMakeLists.txt
parente70b7c1222506a881b4166c67803c467e1985bbc (diff)
downloaddino-148cf48d2b68354881066e2587e2673c91d2619a.tar.gz
dino-148cf48d2b68354881066e2587e2673c91d2619a.zip
Add libnice and listen for direct connections in Jingle SOCKS5 (#608)
Add libnice as a plugin. If it is present, use libnice to enumerate local IP addresses and listen on them to support direct connections for Jingle SOCKS5. Tested with Conversations and Gajim. Created the nice.vapi file using ``` vapigen --library nice --pkg gio-2.0 --metadatadir metadata /usr/share/gir-1.0/Nice-0.1.gir ```
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index b738b585..2af0719b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -11,7 +11,7 @@ else ()
endif ()
# Prepare Plugins
-set(DEFAULT_PLUGINS omemo;openpgp;http-files)
+set(DEFAULT_PLUGINS omemo;openpgp;http-files;ice)
foreach (plugin ${DEFAULT_PLUGINS})
if ("$CACHE{DINO_PLUGIN_ENABLED_${plugin}}" STREQUAL "")
if (NOT DEFINED DINO_PLUGIN_ENABLED_${plugin}})