aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2017-03-23 20:06:00 +0100
committerMarvin W <git@larma.de>2017-03-23 20:06:00 +0100
commit5862e253377a5d6259dfa6a8cc0731f2f7028830 (patch)
tree77283d2f8d572d2055e556e78604a3ec31bb673a /CMakeLists.txt
parentc95a4009081eeafb76670b31416f0e76c511c3e7 (diff)
downloaddino-5862e253377a5d6259dfa6a8cc0731f2f7028830.tar.gz
dino-5862e253377a5d6259dfa6a8cc0731f2f7028830.zip
Find valac-* binaries, work-around fast-vapi issues with valac 0.36.0
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 229abfce..0a6eab42 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -67,6 +67,11 @@ set(CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
set(CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
find_package(Vala 0.30 REQUIRED)
+if(VALA_VERSION VERSION_EQUAL "0.36.0")
+ # Due to a bug on 0.36.0, we need to disable FAST_VAPI
+ set(DISABLE_FAST_VAPI yes)
+endif()
+
include(${VALA_USE_FILE})
include(MultiFind)
include(GlibCompileResourcesSupport)