aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMiquel Lionel <lionel@les-miquelots.net>2024-02-18 19:52:40 +0100
committerMiquel Lionel <lionel@les-miquelots.net>2024-02-18 19:52:40 +0100
commitf27385d952a7400902a58e67d02a6089e2de6289 (patch)
tree1f17c9502b4c14352dd6d41f2d747ac38f3b9705 /CMakeLists.txt
parent4f950d401b2feb799b20e3231e6f09b892614a8c (diff)
downloaddino-f27385d952a7400902a58e67d02a6089e2de6289.tar.gz
dino-f27385d952a7400902a58e67d02a6089e2de6289.zip
More noticeable encryption type color and encryption status
- added file changes-allow-symbolic from GTK Adwaita icon theme as dino-unencrypted.svg (licensed under LGPL3)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 1365b6d2..b4fe6e7c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -103,6 +103,8 @@ endif ()
# Flags for all C files
AddCFlagIfSupported(CMAKE_C_FLAGS -Wall)
+AddCFlagIfSupported(CMAKE_C_FLAGS -Wno-incompatible-pointer-types-discards-qualifiers)
+AddCFlagIfSupported(CMAKE_C_FLAGS --disable-warnings-as-errors)
AddCFlagIfSupported(CMAKE_C_FLAGS -Wextra)
AddCFlagIfSupported(CMAKE_C_FLAGS -Werror=format-security)
AddCFlagIfSupported(CMAKE_C_FLAGS -Wno-duplicate-decl-specifier)