aboutsummaryrefslogtreecommitdiff
path: root/libdino/CMakeLists.txt
diff options
context:
space:
mode:
authorMathieu Bridon <bochecha@daitauha.fr>2018-01-09 20:39:45 +0100
committerfiaxh <fiaxh@users.noreply.github.com>2018-01-09 20:39:45 +0100
commit5557c03be87a622fa830b26e27ca6b158093937c (patch)
tree6540ebe204e58e2196ba4ba75284dc38d241ebe2 /libdino/CMakeLists.txt
parent5d6cf9d8d56f9f3f781d1e6afa149f736868a108 (diff)
downloaddino-5557c03be87a622fa830b26e27ca6b158093937c.tar.gz
dino-5557c03be87a622fa830b26e27ca6b158093937c.zip
Move to GNetworkMonitor (#236)
* Move to GNetworkMonitor Dino currently talks to NetworkManager over DBus to know the state of the network. That doesn't work in a Flatpak sandbox by default though, because Flatpak filters DBus communications and only allows a very small set of things to pass (which are known to be safe). Gio provides an API to know the state of the network (and be notified of changes via a signal): GNetworkMonitor. And GNetworkMonitor works both inside a Flatpak sandbox, and in traditional builds. (in Flatpak it uses what we call a "portal", which are the clean, safe way to let apps exit their sandbox) Fixes #235 * Don't check for network connectivity for now The connectivity check really is the correct thing to do: * network_available means that the computer has network routes to "somewhere". That is, it is connected to a router. * connectivity.FULL means that the computer can access "the Internet". That is, if it is behind a router, that router is connected. As a result, only checking for network_available is not correct. Unfortunately, NetworkManager tends to wait a long time before checking for connectivity. As a result, it is possible that a transient network error leaves NetworkManager thinking that network_available is true but connectivity!=FULL, and it will wait several minutes before realizing that the Internet connexion did come back. During that time, apps checking for connectivity (e.g the whole GNOME desktop) will think they don't have access to the Internet, while apps that don't (e.g Firefox) will access the Internet just fine. Users are understandably confused when that happens. Removing the check for connectivity is an acceptable trade-off in the short-term, until this situation is improved on the NetworkManager side. https://bugzilla.gnome.org/show_bug.cgi?id=792240
Diffstat (limited to 'libdino/CMakeLists.txt')
-rw-r--r--libdino/CMakeLists.txt2
1 files changed, 0 insertions, 2 deletions
diff --git a/libdino/CMakeLists.txt b/libdino/CMakeLists.txt
index 106ddf27..a3fb176f 100644
--- a/libdino/CMakeLists.txt
+++ b/libdino/CMakeLists.txt
@@ -11,8 +11,6 @@ SOURCES
src/application.vala
src/dbus/login1.vala
- src/dbus/network_manager.vala
- src/dbus/network_manager_dbus_properties.vala
src/dbus/upower.vala
src/entity/account.vala