aboutsummaryrefslogtreecommitdiff
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorfiaxh <git@lightrise.org>2018-12-27 12:35:48 +0100
committerfiaxh <git@lightrise.org>2018-12-27 13:01:35 +0100
commit965f4da75ae5a5b308191bd61890b4277504f5b1 (patch)
tree038763267d512b8f64681af80fdeec4e09de6f17 /main/CMakeLists.txt
parentd0d68f5878267320eb99ad544e9117553af11532 (diff)
downloaddino-965f4da75ae5a5b308191bd61890b4277504f5b1.tar.gz
dino-965f4da75ae5a5b308191bd61890b4277504f5b1.zip
Detect emoji-only messages and display them larger
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index d21d10ed..0a21d1f0 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -9,6 +9,7 @@ find_packages(MAIN_PACKAGES REQUIRED
GModule
GObject
GTK3>=3.22
+ ICU>=57
)
set(RESOURCE_LIST
@@ -71,6 +72,7 @@ if(GDK3_WITH_X11)
set(MAIN_EXTRA_OPTIONS ${MAIN_EXTRA_OPTIONS} -D GDK3_WITH_X11)
set(MAIN_EXTRA_PACKAGES ${MAIN_EXTRA_PACKAGES} gdk-x11-3.0)
endif(GDK3_WITH_X11)
+set(MAIN_EXTRA_OPTIONS ${MAIN_EXTRA_OPTIONS} --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi)
vala_precompile(MAIN_VALA_C
SOURCES