aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorhrxi <hrrrxi@gmail.com>2023-06-20 18:54:28 +0200
committerfiaxh <fiaxh@users.noreply.github.com>2023-10-06 15:25:12 +0200
commit715fabb5bb793f35926180363bd6f9236d904f42 (patch)
treedcfbb9f1ed133a197a172307d989399cf64bf6c8 /meson.build
parent3edda368f33c1ffbdcb76c41a32953f50b6ef6bc (diff)
downloaddino-715fabb5bb793f35926180363bd6f9236d904f42.tar.gz
dino-715fabb5bb793f35926180363bd6f9236d904f42.zip
meson: Add omemo plugin
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build5
1 files changed, 5 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 7f86f002..887397c2 100644
--- a/meson.build
+++ b/meson.build
@@ -17,7 +17,12 @@ dep_icu_uc = dependency('icu-uc')
dep_libadwaita = dependency('libadwaita-1')
dep_libcanberra = dependency('libcanberra')
dep_libgcrypt = dependency('libgcrypt')
+dep_libqrencode = dependency('libqrencode')
dep_libsrtp2 = dependency('libsrtp2')
+# libsignal-protocol-c has a history of breaking compatibility on the patch level
+# we'll have to check compatibility for every new release
+# distro maintainers may update this dependency after compatibility tests
+dep_libsignal_protocol_c = dependency('libsignal-protocol-c', version: ['>=2.3.2', '<2.3.4'])
dep_libsoup = dependency('libsoup-3.0')
dep_nice = dependency('nice', version: '>=0.1.15')
dep_m = meson.get_compiler('c').find_library('m', required: false)