aboutsummaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorhrxi <hrrrxi@gmail.com>2023-10-18 18:04:42 +0200
committerfiaxh <fiaxh@users.noreply.github.com>2023-11-13 22:27:50 +0100
commite93e14b12c852f2c78335139c12ffa3f56584c01 (patch)
tree7e0a8193f5988924979a8b5650ce377a95fae225 /meson.build
parent86b101900c28a09ebc6bcbf212f9969f70ce51b7 (diff)
downloaddino-e93e14b12c852f2c78335139c12ffa3f56584c01.tar.gz
dino-e93e14b12c852f2c78335139c12ffa3f56584c01.zip
rtp plugin doesn't depend on GnuTLS
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build10
1 files changed, 1 insertions, 9 deletions
diff --git a/meson.build b/meson.build
index 4ad18477..23a7b3d1 100644
--- a/meson.build
+++ b/meson.build
@@ -17,19 +17,11 @@ foreach plugin : ['plugin-ice', 'plugin-omemo', 'plugin-rtp']
endif
endforeach
-if get_option('plugin-ice').enabled() and not get_option('plugin-rtp').enabled()
- dep_gnutls_required = get_option('plugin-ice')
-elif get_option('plugin-ice').allowed() and not get_option('plugin-rtp').allowed()
- dep_gnutls_required = get_option('plugin-ice')
-else
- dep_gnutls_required = get_option('plugin-rtp')
-endif
-
dep_gdk_pixbuf = dependency('gdk-pixbuf-2.0')
dep_gee = dependency('gee-0.8')
dep_gio = dependency('gio-2.0')
dep_glib = dependency('glib-2.0')
-dep_gnutls = dependency('gnutls', disabler: true, required: dep_gnutls_required)
+dep_gnutls = dependency('gnutls', disabler: true, required: get_option('plugin-ice'))
dep_gmodule = dependency('gmodule-2.0')
dep_gpgme = dependency('gpgme', disabler: true, required: get_option('plugin-openpgp'))
dep_gstreamer = dependency('gstreamer-1.0', disabler: true, required: get_option('plugin-rtp'))