aboutsummaryrefslogtreecommitdiff
path: root/plugins/crypto-vala/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2021-04-11 15:12:53 +0200
committerMarvin W <git@larma.de>2021-04-11 15:13:22 +0200
commit4edab3c8d63b327dcb48799e174a3e00192721ec (patch)
treef4393a6fe2d4dab0c0fe7ae866b20faf17730f37 /plugins/crypto-vala/CMakeLists.txt
parente9ff660537f7c00281395f8a001f7554e116efff (diff)
downloaddino-4edab3c8d63b327dcb48799e174a3e00192721ec.tar.gz
dino-4edab3c8d63b327dcb48799e174a3e00192721ec.zip
Fix custom vapi integration
Diffstat (limited to 'plugins/crypto-vala/CMakeLists.txt')
-rw-r--r--plugins/crypto-vala/CMakeLists.txt6
1 files changed, 2 insertions, 4 deletions
diff --git a/plugins/crypto-vala/CMakeLists.txt b/plugins/crypto-vala/CMakeLists.txt
index 4a8da241..f615854c 100644
--- a/plugins/crypto-vala/CMakeLists.txt
+++ b/plugins/crypto-vala/CMakeLists.txt
@@ -1,9 +1,9 @@
find_package(GCrypt REQUIRED)
+find_package(Srtp2 REQUIRED)
find_packages(CRYPTO_VALA_PACKAGES REQUIRED
GLib
GObject
GIO
- Srtp2
)
vala_precompile(CRYPTO_VALA_C
@@ -18,8 +18,6 @@ CUSTOM_VAPIS
"${CMAKE_CURRENT_SOURCE_DIR}/vapi/libsrtp2.vapi"
PACKAGES
${CRYPTO_VALA_PACKAGES}
-OPTIONS
- --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi
GENERATE_VAPI
crypto-vala
GENERATE_HEADER
@@ -29,6 +27,6 @@ GENERATE_HEADER
set(CFLAGS ${VALA_CFLAGS})
add_definitions(${CFLAGS})
add_library(crypto-vala STATIC ${CRYPTO_VALA_C})
-target_link_libraries(crypto-vala ${CRYPTO_VALA_PACKAGES} gcrypt)
+target_link_libraries(crypto-vala ${CRYPTO_VALA_PACKAGES} gcrypt libsrtp2)
set_property(TARGET crypto-vala PROPERTY POSITION_INDEPENDENT_CODE ON)