aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2021-04-29 15:46:06 +0200
committerMarvin W <git@larma.de>2021-04-29 15:53:59 +0200
commit3880628de4785db4c0a03a79a0c486507fe9b1a8 (patch)
tree488180882a2a60576c68e688b743acfaff8d32f7 /plugins/rtp/CMakeLists.txt
parent328c3cf37f296f4519829afd03d21f94ea4153e5 (diff)
downloaddino-3880628de4785db4c0a03a79a0c486507fe9b1a8.tar.gz
dino-3880628de4785db4c0a03a79a0c486507fe9b1a8.zip
Video optimizations
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
index 76d6e66d..92ec1b97 100644
--- a/plugins/rtp/CMakeLists.txt
+++ b/plugins/rtp/CMakeLists.txt
@@ -1,3 +1,4 @@
+find_package(GstRtp REQUIRED)
find_packages(RTP_PACKAGES REQUIRED
Gee
GLib
@@ -27,6 +28,7 @@ CUSTOM_VAPIS
${CMAKE_BINARY_DIR}/exports/xmpp-vala.vapi
${CMAKE_BINARY_DIR}/exports/dino.vapi
${CMAKE_BINARY_DIR}/exports/qlite.vapi
+ ${CMAKE_CURRENT_SOURCE_DIR}/vapi/gstreamer-rtp-1.0.vapi
PACKAGES
${RTP_PACKAGES}
DEFINITIONS
@@ -35,7 +37,7 @@ DEFINITIONS
add_definitions(${VALA_CFLAGS} -DG_LOG_DOMAIN="rtp" -I${CMAKE_CURRENT_SOURCE_DIR}/src)
add_library(rtp SHARED ${RTP_VALA_C})
-target_link_libraries(rtp libdino crypto-vala ${RTP_PACKAGES})
+target_link_libraries(rtp libdino crypto-vala ${RTP_PACKAGES} gstreamer-rtp-1.0)
set_target_properties(rtp PROPERTIES PREFIX "")
set_target_properties(rtp PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/plugins/)