aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2021-12-18 21:45:36 +0100
committerMarvin W <git@larma.de>2021-12-18 21:45:36 +0100
commit9aeff4bf9e00624187931c0d358c166f5a6860a1 (patch)
treecac26c111dc2d8b818d863b1b11ceb38e4e9a8a4 /plugins/rtp/CMakeLists.txt
parent4f80a9f5ccea5eaf6a78a841af417c597eb7db73 (diff)
downloaddino-9aeff4bf9e00624187931c0d358c166f5a6860a1.tar.gz
dino-9aeff4bf9e00624187931c0d358c166f5a6860a1.zip
SRTP: Do not continue processing data after encrypt/decrypt failed
RTP: Copy less
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
index 3264e24a..fa4f367c 100644
--- a/plugins/rtp/CMakeLists.txt
+++ b/plugins/rtp/CMakeLists.txt
@@ -16,6 +16,10 @@ if(GstRtp_VERSION VERSION_GREATER "1.16")
set(RTP_DEFINITIONS GST_1_16)
endif()
+if(Vala_VERSION VERSION_GREATER "0.50")
+ set(RTP_DEFINITIONS VALA_0_50)
+endif()
+
if(WebRTCAudioProcessing_VERSION GREATER "0.4")
message(STATUS "Ignoring WebRTCAudioProcessing, only versions < 0.4 supported so far")
unset(WebRTCAudioProcessing_FOUND)