aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2022-07-27 19:41:05 +0200
committerfiaxh <git@lightrise.org>2022-07-27 20:55:54 +0200
commite51b55432fe98e0fbc036fe785ef50fbf1589034 (patch)
tree3f4737de32d1c9ef4f68b397394a0d7ac1f89d2a /plugins/rtp/CMakeLists.txt
parentf44cbe02c17df1f02ad49c63cd784fec0ea02d85 (diff)
downloaddino-e51b55432fe98e0fbc036fe785ef50fbf1589034.tar.gz
dino-e51b55432fe98e0fbc036fe785ef50fbf1589034.zip
Gtk4 bug fixes and improvements
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
index 33903d88..3a24c31c 100644
--- a/plugins/rtp/CMakeLists.txt
+++ b/plugins/rtp/CMakeLists.txt
@@ -28,6 +28,10 @@ if(GstRtp_VERSION VERSION_GREATER "1.20")
set(RTP_DEFINITIONS ${RTP_DEFINITIONS} GST_1_20)
endif()
+if(VALA_VERSION VERSION_GREATER "0.56.1")
+ set(RTP_DEFINITIONS ${RTP_DEFINITIONS} VALA_0_56_1)
+endif()
+
set(RTP_ENABLE_VP9 "no" CACHE BOOL "Enable VP9 support")
if(RTP_ENABLE_VP9)
set(RTP_DEFINITIONS ${RTP_DEFINITIONS} ENABLE_VP9)