aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2021-03-21 12:41:38 +0100
committerMarvin W <git@larma.de>2021-03-21 12:41:38 +0100
commitef2e3c774cab82a94a5e34399f2013d64c3cf03b (patch)
treedee0b7184eb2e225593508d74b25a8228e35144f /plugins/rtp/CMakeLists.txt
parente6a933ad307116952d3202c36d0a8d6e7f4b0946 (diff)
downloaddino-ef2e3c774cab82a94a5e34399f2013d64c3cf03b.tar.gz
dino-ef2e3c774cab82a94a5e34399f2013d64c3cf03b.zip
Add RTP implementation as plugin
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
new file mode 100644
index 00000000..2b66f6ff
--- /dev/null
+++ b/plugins/rtp/CMakeLists.txt
@@ -0,0 +1,36 @@
+find_packages(RTP_PACKAGES REQUIRED
+ Gee
+ GLib
+ GModule
+ GObject
+ GTK3
+ Gst
+ GstApp
+)
+
+vala_precompile(RTP_VALA_C
+SOURCES
+ src/codec_util.vala
+ src/device.vala
+ src/module.vala
+ src/plugin.vala
+ src/stream.vala
+ src/video_widget.vala
+ src/register_plugin.vala
+CUSTOM_VAPIS
+ ${CMAKE_BINARY_DIR}/exports/xmpp-vala.vapi
+ ${CMAKE_BINARY_DIR}/exports/dino.vapi
+ ${CMAKE_BINARY_DIR}/exports/qlite.vapi
+PACKAGES
+ ${RTP_PACKAGES}
+OPTIONS
+ --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi
+)
+
+add_definitions(${VALA_CFLAGS} -DG_LOG_DOMAIN="rtp")
+add_library(rtp SHARED ${RTP_VALA_C})
+target_link_libraries(rtp libdino ${RTP_PACKAGES})
+set_target_properties(rtp PROPERTIES PREFIX "")
+set_target_properties(rtp PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/plugins/)
+
+install(TARGETS rtp ${PLUGIN_INSTALL})