aboutsummaryrefslogtreecommitdiff
path: root/plugins/signal-protocol/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2020-01-21 21:30:21 +0100
committerMarvin W <git@larma.de>2020-01-21 21:55:08 +0100
commit55b148a0f78c1abef57c21b2a84d97cad32b2290 (patch)
tree8b3db2a9e9594316e281e3006b098f2762e8b3b8 /plugins/signal-protocol/CMakeLists.txt
parent4c3800c688f87482cdf79c4ecb1c7764ff01e213 (diff)
downloaddino-55b148a0f78c1abef57c21b2a84d97cad32b2290.tar.gz
dino-55b148a0f78c1abef57c21b2a84d97cad32b2290.zip
Use system provided libsignal-protocol-c by default
You can still compile in tree by using --with-libsignal-in-tree flag
Diffstat (limited to 'plugins/signal-protocol/CMakeLists.txt')
-rw-r--r--plugins/signal-protocol/CMakeLists.txt9
1 files changed, 6 insertions, 3 deletions
diff --git a/plugins/signal-protocol/CMakeLists.txt b/plugins/signal-protocol/CMakeLists.txt
index 4c619c86..0ae84111 100644
--- a/plugins/signal-protocol/CMakeLists.txt
+++ b/plugins/signal-protocol/CMakeLists.txt
@@ -28,8 +28,11 @@ GENERATE_HEADER
set(C_HEADERS_SRC "")
set(C_HEADERS_TARGET "")
-if((SHARED_SIGNAL_PROTOCOL) OR ($ENV{SHARED_SIGNAL_PROTOCOL}))
- find_package(SignalProtocol REQUIRED)
+if(NOT BUILD_LIBSIGNAL_IN_TREE)
+ # libsignal-protocol-c has a history of breaking compatibility on the patch level
+ # we'll have to check compatibility for every new release
+ # distro maintainers may update this dependency after compatibility tests
+ find_package(SignalProtocol 2.3.2 EXACT REQUIRED)
else()
add_subdirectory(libsignal-protocol-c EXCLUDE_FROM_ALL)
set_property(TARGET curve25519 PROPERTY POSITION_INDEPENDENT_CODE ON)
@@ -129,4 +132,4 @@ if(BUILD_TESTS)
add_executable(signal-protocol-vala-test ${SIGNAL_TEST_VALA_C})
add_dependencies(signal-protocol-vala-test signal-protocol-vala)
target_link_libraries(signal-protocol-vala-test signal-protocol-vala ${SIGNAL_PROTOCOL_PACKAGES})
-endif(BUILD_TESTS) \ No newline at end of file
+endif(BUILD_TESTS)