aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2019-12-22 04:10:53 +0100
committerMarvin W <git@larma.de>2019-12-23 16:58:53 +0100
commita0a956ee0878d24bd06be7f5d75dc4ccd4e7901d (patch)
treecbb079649066c2001b6d6881137108e70eed9d3f /xmpp-vala/CMakeLists.txt
parent3218dc0211ac717230fe03fad82681a626d968b5 (diff)
downloaddino-a0a956ee0878d24bd06be7f5d75dc4ccd4e7901d.tar.gz
dino-a0a956ee0878d24bd06be7f5d75dc4ccd4e7901d.zip
Properly check Jids everywhere
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index e059b068..246f0108 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -4,6 +4,7 @@ find_packages(ENGINE_PACKAGES REQUIRED
GIO
GLib
GObject
+ ICU
)
set(ENGINE_DEFINITIONS "")
@@ -15,6 +16,7 @@ if(GIO_VERSION VERSION_GREATER "2.60")
else()
message(STATUS "No ALPN support, needs GIO >= 2.60")
endif()
+set(ENGINE_EXTRA_OPTIONS ${MAIN_EXTRA_OPTIONS} --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi)
vala_precompile(ENGINE_VALA_C
SOURCES
@@ -104,6 +106,8 @@ CUSTOM_VAPIS
"${CMAKE_CURRENT_SOURCE_DIR}/src/glib_fixes.vapi"
DEFINITIONS
${ENGINE_DEFINITIONS}
+OPTIONS
+ ${ENGINE_EXTRA_OPTIONS}
)
add_custom_target(xmpp-vala-vapi
@@ -128,12 +132,15 @@ if(BUILD_TESTS)
"tests/common.vala"
"tests/testcase.vala"
+ "tests/jid.vala"
"tests/stanza.vala"
"tests/util.vala"
CUSTOM_VAPIS
${CMAKE_BINARY_DIR}/exports/xmpp-vala_internal.vapi
PACKAGES
${ENGINE_PACKAGES}
+ OPTIONS
+ ${ENGINE_EXTRA_OPTIONS}
)
add_definitions(${VALA_CFLAGS})