aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2019-12-17 23:52:05 +0100
committerMarvin W <git@larma.de>2019-12-18 00:51:49 +0100
commitbd45fdf1e16e7d4ff49e1472ee30f269867f531e (patch)
tree4e9766553fa0dbb48eebe77ab9a4f0a9ad8d2627 /xmpp-vala/CMakeLists.txt
parenta4a795af333d6bcf378e11df456a858af2fa4603 (diff)
downloaddino-bd45fdf1e16e7d4ff49e1472ee30f269867f531e.tar.gz
dino-bd45fdf1e16e7d4ff49e1472ee30f269867f531e.zip
Add version and adjust some cmake
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index 57347282..e4f94dff 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -18,8 +18,6 @@ endif()
vala_precompile(ENGINE_VALA_C
SOURCES
- "src/glib_fixes.vapi"
-
"src/core/namespace_state.vala"
"src/core/stanza_attribute.vala"
"src/core/stanza_node.vala"
@@ -101,6 +99,8 @@ GENERATE_VAPI
xmpp-vala
GENERATE_HEADER
xmpp-vala
+CUSTOM_VAPIS
+ "${CMAKE_CURRENT_SOURCE_DIR}/src/glib_fixes.vapi"
DEFINITIONS
${ENGINE_DEFINITIONS}
)