aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
new file mode 100644
index 00000000..ff7bbc70
--- /dev/null
+++ b/CMakeLists.txt
@@ -0,0 +1,25 @@
+list(APPEND CMAKE_MODULE_PATH
+ ${CMAKE_SOURCE_DIR}/cmake
+)
+
+include(CheckCCompilerFlag)
+macro(AddCFlagIfSupported flag test)
+ CHECK_C_COMPILER_FLAG(${flag} ${test})
+ if(${${test}})
+ set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${flag}")
+ endif()
+endmacro()
+
+cmake_minimum_required(VERSION 3.0)
+
+if("Ninja" STREQUAL ${CMAKE_GENERATOR})
+ AddCFlagIfSupported(-fdiagnostics-color COMPILER_SUPPORTS_fdiagnistics-color)
+endif()
+
+set (CMAKE_RUNTIME_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+set (CMAKE_LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR})
+set (VALA_CFLAGS -Wno-deprecated-declarations -Wno-incompatible-pointer-types -Wno-int-conversion)
+
+add_subdirectory(qlite)
+add_subdirectory(vala-xmpp)
+add_subdirectory(client)