aboutsummaryrefslogtreecommitdiff
path: root/plugins/notification-sound/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'plugins/notification-sound/CMakeLists.txt')
-rw-r--r--plugins/notification-sound/CMakeLists.txt28
1 files changed, 28 insertions, 0 deletions
diff --git a/plugins/notification-sound/CMakeLists.txt b/plugins/notification-sound/CMakeLists.txt
new file mode 100644
index 00000000..85963d25
--- /dev/null
+++ b/plugins/notification-sound/CMakeLists.txt
@@ -0,0 +1,28 @@
+find_packages(NOTIFICATION_SOUND_PACKAGES REQUIRED
+ Canberra
+ Gee
+ GLib
+ GModule
+ GObject
+ GDKPixbuf2
+)
+
+vala_precompile(NOTIFICATION_SOUND_VALA_C
+SOURCES
+ src/plugin.vala
+ src/register_plugin.vala
+CUSTOM_VAPIS
+ ${CMAKE_BINARY_DIR}/exports/xmpp-vala.vapi
+ ${CMAKE_BINARY_DIR}/exports/dino.vapi
+ ${CMAKE_BINARY_DIR}/exports/qlite.vapi
+PACKAGES
+ ${NOTIFICATION_SOUND_PACKAGES}
+)
+
+add_definitions(${VALA_CFLAGS})
+add_library(notification-sound SHARED ${NOTIFICATION_SOUND_VALA_C})
+target_link_libraries(notification-sound libdino ${NOTIFICATION_SOUND_PACKAGES})
+set_target_properties(notification-sound PROPERTIES PREFIX "")
+set_target_properties(notification-sound PROPERTIES LIBRARY_OUTPUT_DIRECTORY ${CMAKE_BINARY_DIR}/plugins/)
+
+install(TARGETS notification-sound ${PLUGIN_INSTALL})