aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt11
1 files changed, 6 insertions, 5 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index 240ee02e..b94d6d22 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -65,17 +65,18 @@ GENERATE_HEADER
xmpp-vala
)
-add_definitions(${VALA_CFLAGS})
-add_library(xmpp-vala SHARED ${ENGINE_VALA_C})
-target_link_libraries(xmpp-vala ${ENGINE_PACKAGES})
-set_target_properties(xmpp-vala PROPERTIES VERSION 0.1 SOVERSION 0)
-
add_custom_target(xmpp-vala-vapi
DEPENDS
${CMAKE_BINARY_DIR}/exports/xmpp-vala.vapi
${CMAKE_BINARY_DIR}/exports/xmpp-vala.deps
)
+add_definitions(${VALA_CFLAGS})
+add_library(xmpp-vala SHARED ${ENGINE_VALA_C})
+add_dependencies(xmpp-vala xmpp-vala-vapi)
+target_link_libraries(xmpp-vala ${ENGINE_PACKAGES})
+set_target_properties(xmpp-vala PROPERTIES VERSION 0.1 SOVERSION 0)
+
install(TARGETS xmpp-vala ${TARGET_INSTALL})
install(FILES ${CMAKE_BINARY_DIR}/exports/xmpp-vala.vapi ${CMAKE_BINARY_DIR}/exports/xmpp-vala.deps DESTINATION ${VAPI_INSTALL_DIR})
install(FILES ${CMAKE_BINARY_DIR}/exports/xmpp-vala.h DESTINATION ${INCLUDE_INSTALL_DIR}) \ No newline at end of file