summaryrefslogtreecommitdiff
path: root/PKGBUILD
diff options
context:
space:
mode:
authorMiquel Lionel <lionel@les-miquelots.net>2021-05-07 19:52:05 +0100
committerMiquel Lionel <lionel@les-miquelots.net>2021-05-07 19:52:05 +0100
commite09875f18e32f37001182170a3f4fb2fc1918e45 (patch)
tree7a80434ecc92ec70943c5fa20110751e4d2e1550 /PKGBUILD
parent8e69d469111d67ec8ad055a257eff81ac2bfe46e (diff)
downloadhonk_aur-e09875f18e32f37001182170a3f4fb2fc1918e45.tar.gz
honk_aur-e09875f18e32f37001182170a3f4fb2fc1918e45.zip
useful abstractions and fix lie in honk.install
- the binary is launched with the 'honk' user, not the 'nobody' user
Diffstat (limited to 'PKGBUILD')
-rw-r--r--PKGBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 06a342e..47ef7ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=honk
pkgver=0.9.6
-pkgrel=3
+pkgrel=4
epoch=0
pkgdesc="ActivityPub compatible server with web frontend."
arch=("x86_64")
@@ -11,7 +11,7 @@ url="https://humungus.tedunangst.com/r/honk"
license=("custom:ISC")
makedepends=("gcc-go" "sqlite")
depends=("gcc-go" "sqlite")
-optdepends=("nginx: reverse proxy with tls support")
+optdepends=("nginx: for TLS and reverse proxying")
changelog="$pkgname.changelog"
provides=("${pkgname}")
conflicts=("${pkgname}")
@@ -27,8 +27,8 @@ build() {
}
package() {
- _PKG_HONKDIR="$pkgdir/usr/share/webapps/honk"
- install -vDm700 "$pkgname-$pkgver/honk" "$_PKG_HONKDIR/honk"
+ _PKG_HONKDIR="$pkgdir/usr/share/webapps/$pkgname"
+ install -vDm700 "$pkgname-$pkgver/$pkgname" "$_PKG_HONKDIR/$pkgname"
install -vDm644 "$pkgname-$pkgver"/views/* -t "$_PKG_HONKDIR/views/"
install -vDm644 "$pkgname-$pkgver"/docs/* -t "$_PKG_HONKDIR/docs/"
install -vDm644 "$pkgname-$pkgver"/LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"