aboutsummaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorlink2xt <link2xt@testrun.org>2021-03-16 03:28:24 +0300
committerlink2xt <link2xt@testrun.org>2021-03-16 03:28:24 +0300
commitb739e3fe86d7b8ecda8ef305306d14ef6f38a1b6 (patch)
treef5f6889de7a21a327c252bbf2684d4818cb2b66f /CMakeLists.txt
parentea24329f4ce7dafd200aa104c2e532048d5dcd2b (diff)
downloadkdeltachat-b739e3fe86d7b8ecda8ef305306d14ef6f38a1b6.tar.gz
kdeltachat-b739e3fe86d7b8ecda8ef305306d14ef6f38a1b6.zip
Compile QML ahead-of-time
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 88f6001..3e7f0cd 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -19,6 +19,12 @@ find_package(QT NAMES Qt6 Qt5 COMPONENTS Core Widgets Quick REQUIRED)
find_package(Qt${QT_VERSION_MAJOR} COMPONENTS Core Widgets Quick REQUIRED)
find_package(PkgConfig REQUIRED)
+# Ahead-of-Time Compilation
+#
+# See https://doc.qt.io/qt-5/qtquick-deployment.html#ahead-of-time-compilation
+find_package(Qt5QuickCompiler)
+qtquick_compiler_add_resources(KDELTACHAT_QML_QRC qml.qrc)
+
add_executable(kdeltachat
main.cpp
message.cpp
@@ -30,7 +36,7 @@ add_executable(kdeltachat
eventemitter.cpp
lot.cpp
dcevent.cpp
- qml.qrc
+ ${KDELTACHAT_QML_QRC}
)
find_package(Threads REQUIRED)