aboutsummaryrefslogtreecommitdiff
path: root/main/CMakeLists.txt
diff options
context:
space:
mode:
authorMathieu Bridon <bochecha@daitauha.fr>2017-12-03 12:15:21 +0100
committerfiaxh <fiaxh@users.noreply.github.com>2018-04-29 14:30:00 +0200
commit0d5735d22e68f5c672d61cef3ab16fa139734fbc (patch)
tree09c97763d8e92737c064b63b7859130ffc1485b9 /main/CMakeLists.txt
parente80da806022d8aaa32f77f3c7f0333cc1c80829b (diff)
downloaddino-0d5735d22e68f5c672d61cef3ab16fa139734fbc.tar.gz
dino-0d5735d22e68f5c672d61cef3ab16fa139734fbc.zip
Add an appdata file
This allows "app center" applications like GNOME Software and Plasma Discover to show Dino in all its glory, so users can install it simply.
Diffstat (limited to 'main/CMakeLists.txt')
-rw-r--r--main/CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/main/CMakeLists.txt b/main/CMakeLists.txt
index 689610a7..2a5377a1 100644
--- a/main/CMakeLists.txt
+++ b/main/CMakeLists.txt
@@ -151,6 +151,7 @@ if(WIN32)
endif(WIN32)
install(TARGETS dino ${TARGET_INSTALL})
+install(FILES data/im.dino.Dino.appdata.xml DESTINATION ${APPDATA_FILE_INSTALL_DIR})
install(FILES data/im.dino.Dino.desktop DESTINATION ${DESKTOP_FILE_INSTALL_DIR})
install(FILES data/im.dino.Dino.service DESTINATION ${SERVICE_FILE_INSTALL_DIR})
install(FILES data/icons/im.dino.Dino.svg DESTINATION ${ICON_INSTALL_DIR}/hicolor/scalable/apps)