aboutsummaryrefslogtreecommitdiff
path: root/plugins/rtp/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2022-01-21 15:23:38 +0100
committerMarvin W <git@larma.de>2022-01-21 15:23:38 +0100
commit37cfbd8c76a457ca6fc882eefde0764cbd10f096 (patch)
tree0f95bd4b7802e289fea19fbe5df2c43fe12f2935 /plugins/rtp/CMakeLists.txt
parenteefce3fd81d7fcb349acb073941ebf5ca9140507 (diff)
downloaddino-37cfbd8c76a457ca6fc882eefde0764cbd10f096.tar.gz
dino-37cfbd8c76a457ca6fc882eefde0764cbd10f096.zip
RTP: Use VP8 wait-for-keyframe only for GStreamer 1.18+
Diffstat (limited to 'plugins/rtp/CMakeLists.txt')
-rw-r--r--plugins/rtp/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/plugins/rtp/CMakeLists.txt b/plugins/rtp/CMakeLists.txt
index 3a121a13..4c159c1b 100644
--- a/plugins/rtp/CMakeLists.txt
+++ b/plugins/rtp/CMakeLists.txt
@@ -16,6 +16,10 @@ if(GstRtp_VERSION VERSION_GREATER "1.16")
set(RTP_DEFINITIONS GST_1_16)
endif()
+if(GstRtp_VERSION VERSION_GREATER "1.18")
+ set(RTP_DEFINITIONS GST_1_18)
+endif()
+
if(Vala_VERSION VERSION_GREATER "0.50")
set(RTP_DEFINITIONS VALA_0_50)
endif()