aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
authorMarvin W <git@larma.de>2022-11-04 15:29:18 -0600
committerMarvin W <git@larma.de>2022-11-04 15:45:48 -0600
commite62955d3cf266a7f7ff0f2085a64f1c99021127c (patch)
treea376d6f6c8f7d040635ee213d031789177e1b3af /xmpp-vala/CMakeLists.txt
parent6e37f3fe3fa0f4ce9a25a91e9d97191c8e4abec1 (diff)
downloaddino-e62955d3cf266a7f7ff0f2085a64f1c99021127c.tar.gz
dino-e62955d3cf266a7f7ff0f2085a64f1c99021127c.zip
HTTP: Make LimitInputStream pollable for better async compatibility
Fixes #1307
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index de89f326..0513d597 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -7,15 +7,6 @@ find_packages(ENGINE_PACKAGES REQUIRED
ICU
)
-set(ENGINE_DEFINITIONS "")
-
-find_package(GIO)
-if(GIO_VERSION VERSION_GREATER "2.60")
- message(STATUS "ALPN support enabled")
- set(ENGINE_DEFINITIONS ALPN_SUPPORT)
-else()
- message(STATUS "No ALPN support, needs GIO >= 2.60")
-endif()
set(ENGINE_EXTRA_OPTIONS ${MAIN_EXTRA_OPTIONS} --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi)
vala_precompile(ENGINE_VALA_C
@@ -154,8 +145,6 @@ GENERATE_HEADER
xmpp-vala
CUSTOM_VAPIS
"${CMAKE_CURRENT_SOURCE_DIR}/src/glib_fixes.vapi"
-DEFINITIONS
- ${ENGINE_DEFINITIONS}
OPTIONS
${ENGINE_EXTRA_OPTIONS}
)