aboutsummaryrefslogtreecommitdiff
path: root/xmpp-vala/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'xmpp-vala/CMakeLists.txt')
-rw-r--r--xmpp-vala/CMakeLists.txt11
1 files changed, 0 insertions, 11 deletions
diff --git a/xmpp-vala/CMakeLists.txt b/xmpp-vala/CMakeLists.txt
index de89f326..0513d597 100644
--- a/xmpp-vala/CMakeLists.txt
+++ b/xmpp-vala/CMakeLists.txt
@@ -7,15 +7,6 @@ find_packages(ENGINE_PACKAGES REQUIRED
ICU
)
-set(ENGINE_DEFINITIONS "")
-
-find_package(GIO)
-if(GIO_VERSION VERSION_GREATER "2.60")
- message(STATUS "ALPN support enabled")
- set(ENGINE_DEFINITIONS ALPN_SUPPORT)
-else()
- message(STATUS "No ALPN support, needs GIO >= 2.60")
-endif()
set(ENGINE_EXTRA_OPTIONS ${MAIN_EXTRA_OPTIONS} --vapidir=${CMAKE_CURRENT_SOURCE_DIR}/vapi)
vala_precompile(ENGINE_VALA_C
@@ -154,8 +145,6 @@ GENERATE_HEADER
xmpp-vala
CUSTOM_VAPIS
"${CMAKE_CURRENT_SOURCE_DIR}/src/glib_fixes.vapi"
-DEFINITIONS
- ${ENGINE_DEFINITIONS}
OPTIONS
${ENGINE_EXTRA_OPTIONS}
)